Get in touch
Back
Maintenance

Infrastructure Upgrade

Completed 12 Jun at 08:00am BST.

app.leadgenapp.io forms.leadgenapp.io/ca9b0519-62b4-4202-b153-ab705ff856a9
Completed

Maintenance completed

Posted 12 Jun at 08:00am BST.
Started

We’re thrilled to share some exciting news with you! In our ongoing efforts to provide you with the best possible service, we’ll embark on a significant infrastructure upgrade to enhance performance, reliability, and security.

Please note that our services will be temporarily offline for approximately 4-5 hours during this time.

For further details, visit the LeadGen News page.

Posted 12 Jun at 03:30am BST.