Get in touch
Back
Maintenance

Infrastructure Upgrade

Completed 3 Jul at 08:00am BST.

app.leadgenapp.io forms.leadgenapp.io/ca9b0519-62b4-4202-b153-ab705ff856a9
Completed

Maintenance completed

Posted 3 Jul at 08:00am BST.
Started

We’re thrilled to share some exciting news with you! In our ongoing efforts to provide you with the best possible service, we’ll be embarking on a significant infrastructure upgrade aimed at enhancing performance, reliability, and security.

Please note that during this time, our services will be temporarily offline for approximately 4-6 hours.

For further details, visit the LeadGen News page.

Posted 3 Jul at 02:30am BST.