Get in touch
Back
Maintenance

LeadGen App Maintenance and Upgrades - Revert

Completed 31 Jul at 01:00pm BST.

app.leadgenapp.io forms.leadgenapp.io/ca9b0519-62b4-4202-b153-ab705ff856a9
Completed

Maintenance completed

Posted 31 Jul at 01:00pm BST.
Started

Update (31/07/2024): We are currently working on reverting the changes, which will cause some app downtime. We regret to inform you that there may be some data loss, including leads and forms. However, if you have email notifications enabled or have integrated the form with services like Zapier, you can still access the leads.

Update (31/07/2024): Changes have been reverted and the app is up & running.

For further details, visit the LeadGen News page.

Posted 31 Jul at 12:00pm BST.