Get in touch
Back
Maintenance

LeadGen App Maintenance and Upgrades

Completed 30 Jul at 09:30am BST.

app.leadgenapp.io forms.leadgenapp.io/ca9b0519-62b4-4202-b153-ab705ff856a9
Completed

Maintenance completed

Posted 30 Jul at 09:30am BST.
Started

Update (30/07/2024): Identified issues with some forms.

We are excited to announce that on Tuesday, July 30, 2024, LeadGen App will be undergoing scheduled maintenance to implement significant upgrades to our platform and cloud infrastructure. These improvements are designed to enhance your experience and ensure we continue to deliver top-notch service as we grow.

Maintenance Window: Start: 2:30 AM UTC End: 9:30 AM UTC (approximately)

For further details, visit the LeadGen News page.

Posted 30 Jul at 03:30am BST.