Get in touch
Back
Maintenance

Infrastructure Improvements

Completed .

LeadGen App LeadGen API LeadGen Forms Geoplugin API
Completed

Maintenance completed

Posted .
Started

Key Upgrades:
- Important infrastructure improvements to support future scalability, performance, and reliability.
- Enhancements and prep work for upcoming feature rollouts.

For more details, please visit: https://leadgenapp.io/news

Posted .